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ADuCM320 Development Systems Getting Started Tutorial

DEVELOPMENT SYSTEM KIT CONTENTS

An evaluation board (EVAL-ADuCM320EBZ) that facilitates
performance evaluation of the device with a minimum of
external components

An Analog Devices, Inc., J-Link OB emulator (USB-
SWD/UART-EMUZ)

1 USB cable

1 installation DVD

INTRODUCTION

The ADuCM320 is a dual-die stack system on-chip designed for
diagnostic control on fixed wavelength laser optical module
applications. It features a 16-bit (14-bit accurate) multichannel
SAR ADC, an ARM* Cortex™-M3 processor, 8 voltage DACs,

4 current output DACs, and flash/EE memory packaged in a

6 mm x 6 mm 96 ball BGA package.

GENERAL DESCRIPTION

The ADuCM320 development system allows evaluation of
ADuCM320 silicon. This quick start guide introduces the
support features and the tools supplied with the evaluation
kit. In addition, it shows and describes how to connect the
evaluation hardware.

This guide works as a tutorial by providing a step-by-step
account of how to download evaluation versions of third-
party software tools. Instructions are provided on how to load
code examples that are supplied.

Working through this guide brings users to a stage whereby
they can start to generate and download their own user code
for use in their own unique end-system requirements.

TYPICAL SETUP
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Figure 1. EVAL-ADuCM320EBZ Evaluation Board and Analog Devices J-Link OB Emulator

PLEASE SEE THE LAST PAGE FOR AN IMPORTANT
WARNING AND LEGAL TERMS AND CONDITIONS.

Rev.0|Page 10f4


http://www.analog.com/ADuCM320?doc=ADuCM320_Getting_Started_Guide_UG-692.pdf
http://www.analog.com/ADuCM320?doc=ADuCM320_Getting_Started_Guide_UG-692.pdf
http://www.analog.com/ADuCM320?doc=ADuCM320_Getting_Started_Guide_UG-692.pdf
http://www.analog.com/ADuCM320?doc=ADuCM320_Getting_Started_Guide_UG-692.pdf
http://www.analog.com/ADuCM320?doc=ADuCM320_Getting_Started_Guide_UG-692.pdf
http://www.analog.com/ADuCM320?doc=ADuCM320_Getting_Started_Guide_UG-692.pdf
www.analog.com

UG-692

GETTING STARTED
SOFTWARE INSTALLATION PROCEDURES

Perform the steps described in this section before plugging any
of the USB devices into the PC.

1. Close all open applications.

2. Insert the installation DVD into your DVD drive.

3. Double-click ADuCM320.exe and follow the on-screen
instructions. A menu displays installation options as shown
in Figure 2.
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Figure 2. Installation Options

The following will be installed on your machine by default:

e  FTDI drivers for the evaluation board.

e  Example code and function sets for most peripherals.

e An Elves.exe application to easily choose functions from
the provided function sets and then choose the function
parameters.

The option will be presented to install the following:

e  Keil development tools (compiler, debugger, programming
tools). The revision used is V4.60. Analog Devices has
added a patch to this revision of the MDK460 tools to
support the ADuCM320.

e TAR development tools (compiler, debugger, programming
tools).

e  Segger drivers. These are the drivers for the emulator.

The Segger J-Link software is selected by default in the
installation menu. It is advised to leave it selected. This
automatically installs the J-Link serial port driver. Select Install
USB Driver for J-Link-OB with CDC as shown in Figure 3. If
that step is missed, run JLinkCDClnstaller_V1.2b.exe located
in the ADuCM320\Segger folder.
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Figure 3. Installing Link Software

If the AR tools are to be used, the entire contents of the
supplied arm directory (for example, C:\ADuCM320...\
TAR\IAR_M320_Patch0.2.zip\arm) must be copied to the IAR
tools directory (for example, C:\Program Files\IAR Systems\
Embedded Workbench 6.5 Kickstart\arm).

Future updates may be available from the Analog Devices
FTP site.

KEIL uVISION4

The pVision4 integrated development environment (IDE)
integrates all the tools necessary to edit, assemble, and debug
code. The fastest way to get up and running is to open an
existing project by using the following steps:

1. InKeil uVision, select Project > Open Project.

2. Browse to the folder on the path where the ADuCM320
software was installed (such as, C:\ADuCM320...).

3. Open the file DIO.uvproj in the folder
code\ADuCM320\examples\DIO. This will launch an
example project.

4. Compile and download to the part.

5. To run the code press reset on the board or enter debug
mode and then press Run.

6.  When running, the red LED marked DISPLAY on the
board will flash.
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IAR EWARM

The EWARM integrated development environment (IDE)
integrates all the tools necessary to edit, assemble, and debug
code. The fastest way to get up and running is to open an
existing workspace by using the following steps:

1. Open the IAR tools (from C:\Program Files (x86)\IAR
Systems\Embedded Workbench
6.5\common\binlarldePm.exe).

2. Within the IAR IDE, click File > Open > workspace and
open a workspace provided (for example,
C:\ADuCM320...\code\ADuCM320\examples\DIO\DIO
EWW).

3. Compile and download to the part using Project >
Rebuild all and then to Project > Download Active
application.

4. Click No if a pop-up window about an unknown device
appears.

5. To run the code press reset on the board or enter debug
mode and then press Go.

6. When running, the red LED marked DISPLAY on the
board will flash.

ELVES

Elves.exe is an application to easily choose functions from the
provided function sets and then choose the function
parameters. Elves can be integrated into the Keil and IAR tools
under their tools menus. For instructions, run Elves.exe (for
example, at C:\ADuCM320...\Software Tools\Elves\Elves.exe)
and use the F1 key or the Help button for further instructions.

EVALUATION BOARD SETUP PROCEDURES
Assembling the Hardware

Do not plug in the USB cable before the software is installed.

Connecting the Hardware
Use the following steps to connect the hardware:

1. Insert the USB cable provided between the PC and the J-
Link OB emulator.

2. Thered LED (LED1) will flash briefly until initialization of
drivers is complete.

3. Driver installation details may appear on your screen—
allow the installation of these drivers to complete as these
provide a virtual communication port on your PC allowing
the evaluation board to appear as a virtual serial commu-
nication port to the UART port of the ADuCM320 device.
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If the virtual serial communication port to the UART is to
be used, then ensure Jumpers LK3 and LKS5 are in place
(see Figure 5). If the UART on J8 is to be used, then LK3
and LK5 must be removed to prevent contention.
Plug the 10-pin DIL connector of the J-Link OB emulator
into the EVAL-ADuCM320EBZ.
To power up the evaluation board apply:
e A voltage between4 Vand 5.5V to J5

or
e A voltage between 4.7 V and 6.2 V to J14
The green POWER LED will turn on.
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Figure 4. Emulator, Top View
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Figure 5. J-Link OB Connection Details
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REVISION HISTORY

5/14—Revision 0: Initial Version

ESD Caution
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection
‘m circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality.

Legal Terms and Conditions

By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement. This Agreement is made by and between you (“Customer”) and Analog Devices, Inc.
("ADI"), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal,
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (i) permit any Third Party to access the Evaluation Board. As used herein, the term
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board.
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice
to Customer. Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED
TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL
PROPERTY RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER'S POSSESSION OR USE OF
THE EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI'S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable
United States federal laws and regulations relating to exports. GOVERNING LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed.

©2014 Analog Devices, Inc. All rights reserved. Trademarks and ANALOG
registered trademarks are the property of their respective owners.
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